Error after Bamboo installation

I've followed the instructions (from the Here Be Dragons challenge) to install Bamboo. I have Maven 3.x installed. When I go to localhost:8085/bamboo, it spits out this:

java.lang.NullPointerException at com.atlassian.bamboo.ww2.BambooFreemarkerManager$1.get(BambooFreemarkerManager.java:103)

 

And there's a lot more after that. What am I doing wrong? Full permissions on folders and JAVA_HOME system variable has been set.

1 answer

1 accepted

0 votes
Accepted answer

Nowhere in the documentation does it say you need JDK6. This is what it needed. I was on 8, since I was sure that's what it said the other applications needed. I Googled and found a reference to JDK6 in the Bamboo 5.3 release notes. Problem solved.

@Gabriel Henton, thanks for note that problem was solved.

Just want to let you know that Bamboo team released version 6.2.1 last week: https://confluence.atlassian.com/bamboo/bamboo-6-2-release-notes-938641951.html

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

185 views 4 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you