Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

DB Installation fails on MSSQL

Connection to MS SQL fails with the following stack trace.

I note in the stack trace ... java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter

Possibly JDK version? 

JAVA_HOME and Path variable are set..... 

Any ideas?

I also tried local DB install but that just hangs....

Stack Trace:

ognl.MethodFailedException: Method "execute" failed for object com.atlassian.bamboo.ww2.actions.setup.SetupDatabaseConnectionAction@6a7d3fc5 [java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter]
	at ognl.OgnlRuntime.callAppropriateMethod(
	at ognl.ObjectMethodAccessor.callMethod(
	at com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor.callMethodWithDebugInfo(
	at com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor.callMethod(
	at ognl.OgnlRuntime.callMethod(
	at ognl.ASTMethod.getValueBody(
	at ognl.SimpleNode.evaluateGetValueBody(
	at ognl.SimpleNode.getValue(
	at ognl.Ognl.getValue(
	at ognl.Ognl.getValue(
	at com.opensymphony.xwork2.ognl.OgnlUtil$3.execute(
	at com.opensymphony.xwork2.ognl.OgnlUtil.compileAndExecuteMethod(
	at com.opensymphony.xwork2.ognl.OgnlUtil.callMethod(
	at com.opensymphony.xwork2.DefaultActionInvocation.invokeAction(
	at com.opensymphony.xwork2.DefaultActionInvocation.invokeActionOnly(
	at org.apache.struts2.interceptor.BackgroundProcess$
	at java.base/
Caused by: java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter
	at java.sql/java.sql.DriverManager.getConnection(
	at java.sql/java.sql.DriverManager.getConnection(
	at com.atlassian.config.bootstrap.DefaultAtlassianBootstrapManager.getTestDatabaseConnection(
	at com.atlassian.bamboo.ww2.actions.setup.SetupDatabaseConnectionAction.createConnection(
	at com.atlassian.bamboo.ww2.actions.setup.SetupDatabaseConnectionAction.validateDatabase(
	at com.atlassian.bamboo.ww2.actions.setup.SetupDatabaseConnectionAction.validateFields(
	at com.atlassian.bamboo.ww2.actions.setup.SetupDatabaseConnectionAction.execute(
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.base/java.lang.reflect.Method.invoke(
	at ognl.OgnlRuntime.invokeMethod(
	at ognl.OgnlRuntime.callAppropriateMethod(
	... 16 more
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter
	at java.base/
	at java.base/java.lang.ClassLoader.loadClass(
	at java.base/java.lang.ClassLoader.loadClass(



1 answer

Ok, seems I managed to solve it.

I initially ran Java 11. Uninstalled it and installed Java 8. Viola - it worked.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bamboo

Bamboo Data Center - Early Access Program 2

We’re preparing for Bamboo 8.0, which will be our first Data Center release. To make sure our app vendors and customers with written in-house apps are prepared, we’re launching Bamboo 8.0 Early Acces...

105 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you