Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,294,746
Community Members
 
Community Events
165
Community Groups

Builds are failing when agent running as a service

Hello Team,

 

I have a windows build agent which is configure to run maven builds. When I started running it as service , build are failing continuously with below error. 

 

Agent log on user is not Local System and ENV variables are correctly configured. Can someone help me to solve this issue.

 

PS: when agent is running as non service, builds are success.

bamboo_error.PNG 

2 answers

0 votes
Jeyanthan I Atlassian Team Apr 10, 2018

Hi Akhil,

I believe the English translation to the error is this:

<cmd> is not recognized as an internal or external command

We see this problem often, and it's often related to the SYSTEM path not working when using the agent as a Windows Service which is outlined in the below knowledge base article:

 Hope that helps.

0 votes
robhit Atlassian Team Apr 09, 2018

Hi Akhil,

The problem may need a thorough investigation. 

I would recommend opening a support ticket so that support engineers can help you.

Thanks,

Robhit

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center on Kubernetes

Hi, If you are running self-managed environments and looking to adopt modern infrastructure, Bamboo Data Center can now be deployed in a Kubernetes cluster. By leveraging Kubernetes, you can easily...

931 views 3 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you