Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Broker URL Setting for Remote Agents over SSL

Hi-  We have a new Bamboo Server running 6.4 and have installed a remote agent on a nearby server.  We have a requirement for the Bamboo server to connect to the remote agent over SSL.  Am seeing errors on the remote agent server that might indicate the Broker URL setting is awry. 

What is the recommended Broker URL and Broker Client URL setting when connecting to remote agent over SSL?

We have tried for Broker URL a setting of

 ssl://<ip address of bamboo server>:443?wireFormat.maxInactivityDuration=300000

and

ssl://<domain name of bamboo server>:443?wireFormat.maxInactivityDuration=300000  (In this case bamboo actually appends the IP address after the domain name somehow)

Neither of those work.  The remote agent logs seem to indicate that Bamboo agent does not like the Broker URL setting(s)

 

On a previous HTTP  installation we had tcp://0.0.0.0:54663.....  SSL was not configured for this, however.

Thanks!

 

1 answer

0 votes

Hi @mattdolantess

You must keep the same address:port and change only the protocol.

As stated in the Securing your remote agents documentation, these are the steps you should follow:

  1. Shut down your Bamboo server and agents.
  2. Change the protocol of your Broker URL and Broker client URL in the bamboo.cfg.xml file to 'SSL'. Note, do not change the address of this URL.<property name="bamboo.jms.broker.uri">ssl://myhost:myport</property><property name="bamboo.jms.broker.client.uri">failover:(ssl://myhost:myport)</property>
  3. Start up the Bamboo server.
  4. Start up the Bamboo agents. If your agents do not start up, please check that you have set up your certificates correctly.

If bamboo is over HTTPS, please also make sure you have the following parameters on the catalina connector in the <installation directory>/conf/server.xml file

            scheme="https"
            proxyName="<bamboo BASE URL>"
            proxyPort="443"

 thanks

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

918 views 4 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you