Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo remote agent for hp-ux

All,

I'm trying to install Bamboo 5.5 remote agents for HP-UX platforms (B.11.31 ia64, B.11.23 ia64, and B.11.11 9000/800 PA-RISC) but I didn't find HP-UX mentioned in supported platform document.  Can anyone give me some insight of  the following questions:

(1) Which Java version do I need for the HP-UX platforms, I assumed it is Java 7 but not sure.

(2) I didn't find wrapper components in the jar installer under the arch folder.  Are wrapper for remote agent on HP-UX platforms available and supported by Atlassian?

Thanks,

JC

 

4 answers

1 accepted

0 votes
Answer accepted

I submitted an Atlassian Support issue and was told that Bamboo 5.6.1 or later should resolve my issue.  I upgraded my Bamboo server to 5.8.1 and remote agents work fine now.  However the required HP Java 8 for Bamboo 5.8.1 is not available and I ended up using HP Java 6 for PA-RISC HP-UX 11.11, HP Java 7 for HP-UX i11.23 and HP Java 8 for HP-UX i11.31.  The remote agents are running so far so good.

0 votes

I'd go with OpenJDK 7 in your case. 

Not available and not supported. You can use the wrapper available online or use some other solution. You don't need the wrapper.

I started bamboo remote agent without the wrapper but got several errors which all related to JNA native support.

For Itanium platform:

Caused by: java.lang.UnsatisfiedLinkError: JNA native support (com/sun/jna/hp-ux-ia64n/libjnidispatch.so) not found in resource path (bamboo-agent-5.5.0.jar)

For PA-RISC platform:

Caused by: java.lang.UnsatisfiedLinkError: JNA native support (com/sun/jna/hp-ux-pa_risc2.0/libjnidispatch.sl) not found in resource path (bamboo-agent-5.5.0.jar)

Has anyone run Bamboo remote agents successfully on the HP-UX platforms?  I appreciate your feedback.

loda lele bhoss dk madhar chod

 

bhen ke land maa ki chut teri ki 

 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

185 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you