Bamboo pull from TFS-Git

I am setting up a new Bamboo server for my company.  We currently use TFS-Git as our source repository.  In creating my first task in Bamboo, I am using a Source Control Checkout task, selecting Git, and then entering all my Git info, including the HTTPS url for my repo and the username and password for my account in TFS.

The task is saved.  When I try to run the build, it fails with a 401 no authentication error.  My confusion comes in the fact that if I RDP into the server that Bamboo is running on, open a git-bash prompt, navigate to the build-dir folder where we have set the working directory to be in Bamboo and preform the clone and checkout from there, it works with no issues.

If feel pretty certain this is a TFS permissions issue, but I am not sure how since I can do the git commands from Git-Bash.

Obviously any assistance at this point would be greatly appreciated as I am all out of ideas.

1 answer

Hi Justin! How are you doing?

When you did the RDP and cloned, you had to enter user and password? Or did TFS get your user info from your windows session?

Thanks,

Cristiano

Thanks for replying.

It either recognized me from my Windows creds or I have cached them the first time I used git-bash in other git cmds, I can't remember. I do know it didn't ask me for them.  They are the same creds that I entered into the task for Bamboo as well.

Cristiano,

Thanks again for the reply.  I followed the posts you mentioned above as closely as I could for my environment including deleting creds in the credential manager, and deleting caches on the TFS server.  I was not able to find a cache at the path specified for the client machine.  I also checked my TFS site in IIS and the only Authentication I have enabled is Windows Authentication.  Unfrotunately, this did not resolve the problem.

Justin

Sorry to hear that!

Are you running builds in a Bamboo Server using Local Agents or Remote Agents? Is it installed as a Windows Service? Are they running under the same windows account you tested when you did the RDP connection?

Bamboo is using a local agent.  It is not installed as a Windows Service.  It is currently using Tomcat with the same RDP creds.

The way I understood the task though, was it used the credentials I supplied in the task.

I suppose Bamboo is sendind them, but TFS ignores them, as it is configured to use Windows Authentication.

If thats the case, I wonder if turning on Basic Authentication as well as Windows Auth would be beneficial.

I think it is worth a try :-)

I tried adding Basic Auth in IIS for TFS as well as enabling Anonymous Auth.  Unfortunately to no avail.

I might have to just start preparing my sales pitch to move away from TFS. :)

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Monday in Jira Ops

Jira Ops Early Access Program Update #1: Announcing our next feature and a new integration

Thanks for signing up for Jira Ops! I’m Matt Ryall, leader for the Jira Ops product team at Atlassian. Since this is a brand new product, we’ll be delivering improvements quickly and sharing updates...

434 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you