Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo not artifacting empty folders

We have build agenst that are not putting empty folders in their artifacts. Our artifact mask is **/* so it should put everything in.

What should we be looking at to determine why these folders aren't getting copied?

(Bamboo 5.3)

Thankfully the local build agent works, so we've put that restriction on for now.

1 answer

0 votes
rsperafico Atlassian Team May 01, 2014

Hi Stephen,

Would be possible to to give it a try by replacing **/* by **, please?

Kind regards,
Rafael

Nope - same result. What library is it using to do these globs - is it really ant? Could it possibly depend on what ant is on the system classpath or something?

It's really ant library and no, we're not using system ant. We are aware that there's an issue with empty dirs - they are sometimes included, sometimes not, depending on OS.

I have the same issue with the latest version of bamboo Atlassian Bamboo version 6.0.3 build 60004 - 07 Jun 17 on a Windows 7 machine, 

do we have a fix ?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center 8.1 is now available

G’day Bamboo customers, Bamboo DC 8.1 is now available with it the following features and programs: SAML 2.0, OpenID Connect, and Crowd SSO In order to help admins with a simplified user manage...

204 views 0 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you