Bamboo is not recognizing ruby.runtime. Please assist

After installing rake plugin(bamboo ruby plugin), I am trying to add a rake task for rake configuration to call ruby based cucumber test scripts.

While configuring the rake configuration task , Bamboo should auto recognize the ruby.runtime and load it, but it is not doing so. I have done multiple checks on "Path" environmental variable to have ruby runtime location also.

Please assist me in resolving this issue.

1 answer

0 vote

You've labelled this question with OnDemand tag. How did you install a plugin on OnDemand?

Sorry for the confusion, I have installed the plugin by placing the jar at

..\Bamboo\webapp\WEB-INF\lib and then restarted the bamboo server.

I have also tried installing the plugin through "plugin manager" in bamboo administration. Still I face the same issue. It is not recognizing ruby executable's path.

Please assist

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,321 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you