Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo git lfs checkouts fail

When I try to checkout from my repo using a "Source Code Checkout" task, I get an error. The created command is "/bin/git lfs fetch ssh://some-uuid@127.0.0.1:40050/misc/main.git refs/heads/master". The output of that command ist "stderr:Invalid remote name "ssh://some-uuid@127.0.0.1:40050/misc/main.git".

That seems to be a misbuilt command. The Bamboo version is 6.0.3 build 60004. The Linked Repository is configured with "Use shallow clones", "Verbose logs" and "Enable LFS support". I also have "filter.lfs.required = true" in the config of the apache user, but "git config --get filter.lfs.required" has return code 1. Is there something I can do?

1 answer

0 votes
Jeyanthan I Atlassian Team Apr 11, 2018

Hi Stefan,

I believe Git LFS is installed on both Server and on the agent side. Can you check if the Git checkout command with the same local account works outside?

I ask this because there was a bug (BAM-18339) in Bamboo 5.15.x where GIT LFS doesn't work correctly if 'Fetch whole repository' option is set in the linked repository.

As a workaround, you will have to disable 'fetch whole repository' option.

Hi Jeyanthan,

thank you very much. "Fetch whole repository" wasn't enabled anyway. But I've found the reason now. The version of git-lfs was a 1.x which does not support URLs as remote. Details are described here. I'm on a 2.4.0 now and it works perfectly.

Best regards

Stefan

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

195 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you