It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo does not pickup $HOME environment variable

Hey guys.

Bamboo seems to ignore my system environment variables which makes some of the tasks fail (composer). I'm running Bamboo 5.6.

I'm essentialy running a "command" task in one of my builds. This runs composer for dependency management and it expects to find a $HOME env variable set.

My bamboo runs through it's own user and when I log in locally I find my env variables just fine. But when bamboo runs they seem to never be set.

I found the following : https://confluence.atlassian.com/display/BAMKB/Bamboo+does+not+pick+up+the+Path+environment+variable+correctlybut I don't know if it's related because I used to test run a bamboo 5.5.x with a similar setup and that worked just fine (though it was running as root.. so maybe the above does apply but I can't set HOME globally)

Any ideas how I could work around this? I'm lost as to what to do.

Thanks


Edit:

Ok I had an idea as this worked. realized that command tasks had an env field. So even though it's tedious I'm using that as a workaround for the moment. Can any of you confirm this is related to the bug I linked?

6 answers

1 accepted

0 votes
Answer accepted

Here's more information on how I solved this in the event it can help anyone:

When setting up the tasks, there's an Environment variables field that can be configured. You can use this to work around the issue.

Capture d’écran 2014-09-24 à 18.44.49.png

As you can see above, I've configured it to use /home/bamboo (my bamboo user home folder) as the $HOME env variable.

Like I mentioned in my original post. It can become quite tedious, but at least it works.

Hope it helps

Thanks, Dylan. Yes, we came to this only solution as well. Having a lot of plans/jobs, the solution doesn't look god... But looks like there is no other way :(

I got it solved through customer support and eventually the reason appeared to be a wrong init.d script that starts Bamboo. In my case, I had an erroneous line in my script as follows:

start)
    echo "Starting $APP"
    /bin/su -m $USER -c "cd $BASE/logs && $BASE/bin/startup.sh &> /dev/null"
    ;;

 

There "-m" part was wrong. The final, solution answer from Support was as following, which solved my problem:

Alright.. I think we have got the root cause. The reason for this behavior is that the startup script uses the 

/bin/su -m $USER -c

Notice the "-m", This means that the environment variables are preserved. So when you change the user to "bamboo", we didn't capture the environment variables from that user but rather, we just use the variables of the user logged in. Please edit the script and remove the "-m" option. This should fix the issue with next reboot. For more information and updated script, please refer to https://confluence.atlassian.com/display/BAMBOO/Running+Bamboo+as+a+Linux+service

Regards

 

But this doesn't solve the REAL problem. I also use Compass SASS preprocessor and it fails as well because $LANG env var isn't picked up as well. To be honest, NONE of the system env vars are being picked.

Have you found a bug report about this or not? Maybe it would be worth bringing this up. It's been a while after all.

Hi Dylan,

 

could you provide more details about the workaround you use?

I have the same issue now and cam't find out how to make Composer run normally.

 

Thanks

Added an answer to this question with my work around. Hope it helps you.

Our bamboo script tasks also lack the HOME env var.  Tilde ('~') is available, however, with an expected value.

Hi,

has anyone found any proper solution for this - why is HOME lacking in Bamboo? Can someone from Atlassian comment this?

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bamboo

Unable to add or edit Bitbucket Cloud repository in Bamboo

On 31 May, a GDPR-related change went live in the Bitbucket Cloud API that resulted in users not being able to create or edit Bitbucket Cloud Linked repositories in Bamboo. This API update removed t...

332 views 2 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you