• Community
  • Products
  • Bamboo
  • Questions
  • Bamboo bootstrap failed: Failed to run pre-bootstrap upgrade tasks. Please contact Atlassian and https://support.atlassian.com

Bamboo bootstrap failed: Failed to run pre-bootstrap upgrade tasks. Please contact Atlassian and https://support.atlassian.com

Bamboo Version: 5.5

While re-starting bamboo server i got Bootstap failed error Below is the Stacktrace for that

java.sql.SQLException: Table not found in statement [select count(next_hi) from hibernate_unique_key]
at org.hsqldb.jdbc.Util.sqlException(Unknown Source)
at org.hsqldb.jdbc.jdbcStatement.fetchResult(Unknown Source)
at org.hsqldb.jdbc.jdbcStatement.executeQuery(Unknown Source)
at com.mchange.v2.c3p0.impl.NewProxyStatement.executeQuery(NewProxyStatement.java:35)
at com.atlassian.bamboo.upgrade.tasks.validation.ThereIsSingleRowInHibernateUniqueKeyTable$1.doInHibernateTransaction(ThereIsSingleRowInHibernateUniqueKeyTable.java:42)
at com.atlassian.bamboo.upgrade.AbstractBootstrapUpgradeTask.withDatabaseConnection(AbstractBootstrapUpgradeTask.java:84)
at com.atlassian.bamboo.upgrade.tasks.validation.ThereIsSingleRowInHibernateUniqueKeyTable.doUpgrade(ThereIsSingleRowInHibernateUniqueKeyTable.java:34)
at com.atlassian.bamboo.upgrade.AbstractUpgradeManager.runUpgradeTask(AbstractUpgradeManager.java:205)
at com.atlassian.bamboo.upgrade.BootstrapUpgradeManagerImpl.runValidationTests(BootstrapUpgradeManagerImpl.java:77)
at com.atlassian.bamboo.setup.DefaultBootstrapManager.performPersistenceUpgrade(DefaultBootstrapManager.java:306)
at com.atlassian.config.bootstrap.DefaultAtlassianBootstrapManager.init(DefaultAtlassianBootstrapManager.java:80)
at com.atlassian.bamboo.setup.BootstrapLoaderListener.contextInitialized(BootstrapLoaderListener.java:75)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4887)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5381)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1559)
at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1549)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
at java.util.concurrent.FutureTask.run(FutureTask.java:166)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:701)

Please help. I am blocked.

4 answers

This widget could not be displayed.

I ran into this same issue.  It appears that the fundamental issue is that it isn't loading the database files into the hsql database.  I'm trying to run integration tests for a plugin and that process attempts to load the hsql db from /<full path to project dir>/target/bamboo/home/database/defaultdb.  The appropriate files exist and it worked fine on my machine, but not on our CI machine*. 

 

It turns out that on our CI machine, the full path contains a capitalized directory name.  I'm not sure if it's bamboo or the hsql drivers or what, but something seems to be lower-casing the connection string and thus it's not finding the hsqldb files.  You should be able to see what connection string it's using in bamboo's output just before you see this exception.  In my case, it looks something like:

jdbcUrl -&gt; jdbc:hsqldb:/mnt/bamboo/home/xml-data/build-dir/MEC-DEP0-JOB1/target
/bamboo/home/database/defaultdb

I verified that the capitals in the connection string are the cause of my problem by capitalizing my project dir on my local machine and seeing it fail.  Unfortunately I haven't figured out how to solve this problem yet other than ensuring that the project isn't put in a directory with capital letters in it.

 

*(Yes, in a fantastic bit of irony, my problem was occurring when trying to run integration tests for a bamboo plugin on our bamboo box itself)

 

Ah...nevermind on the capitalization thing. It turns out to have been a red-herring. The fundamental issue is indeed that the hsql db files aren't being loaded. But the reason it failed for me locally when I changed my directory name was that bamboo.cfg.xml still pointed to my old directory name which no longer existed. So i'm back to not knowing why my hsqsl db files aren't being loaded.

Ok..._now_ i've figured it out. Line 111 of https://bitbucket.org/atlassian/amps/src/8e385d823b22951d258a277f3fcb5a82390a3912/maven-amps-plugin/src/main/java/com/atlassian/maven/plugins/amps/product/BambooProductHandler.java?at=master replaces /bamboo-home/ with /home/ in the config files after it extracts data into the project's home directory. This is a problem for me as there happens to be an unrelated bamboo-home in my file path. (See the above /mnt/bamboo/home in my jdbcUrl in my original post? The real directory is /mnt/bamboo/bamboo-home, but is getting substituted incorrectly). I had to simlink /mnt/bamboo/home -> /mnt/bamboo/bamboo-home and it worked.

This widget could not be displayed.

Same error message for Bamboo 5.9.7 running on Windows.  My Bamboo server machine went down and when I restarted the Bamboo I got this error because I had not started the server in Admin mode.  When I restarted as sysadmin the error went away.

Restarting the Bamboo server (6.0.2) on a Linux machine as sudo did the trick for me too .

This widget could not be displayed.

Was anything ever done with this? I am getting the same error(after getting several others). I have been trying to get bamboo running for 2 days now, and I am beginning to think it never will work. :|

This widget could not be displayed.

same issue here with 5.7.2 version of bamboo.  Any solution?

In my case, it turned out the hard disk had run out space.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published 3 hours ago in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

27 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you