Hi,

I'm trying to build a CI plan with Bamboo using a Stash repo.

I've filled in the settings, but it would appear that the server local git is having issues getting the repo. In the repo settings, I've supplied the repo as:

http://dev.domain.com/git/scm/KEY/ils.git

Git returns: http://dev.domain.com/git/scm/KEY/ils.git/info/refs no valid: is this a git repository?

I can't seem to figure out why.

<body></body>

3 answers

This widget could not be displayed.

Have you taken a look at this thread and referenced documentation?

https://answers.atlassian.com/questions/79166/problem-integrating-bamboo-with-stash

Hi Ellen, I think that this is more of a git problem, as I can even reproduce this using git on the server, but I dont know how to resolve it.

This widget could not be displayed.
Colin Goudie Community Champion Nov 24, 2012

Did you supply a username in the http URL?

i.e. http://username@dev.domain.com/etc...

? Just wondering if stash doesn't route it otherwise

Also, I'm assuming you have data in that git repo and you can successfully clone it from commandline on that server?

Hi Colin,

It seems to be failing at server/gitd level, with the same error as in Bamboo. In Bamboo, I didn't supply the credentials, I used the form itself to supply the credentials.

Colin Goudie Community Champion Nov 24, 2012

Next thing I would check assuming you can git clone fine from another machine, is from the server can you even get to stash? Like using wget or lynx to browse the stash login screen or something?

That git error is indicating that whatever URL you just hit, it's not a git repo, so wondering if there is some routing issue when doing this from your server

Hi Colin,

I would hope that it would see it given that stash and bamboo are on the same machine.

I tried to clone Atlassian UI/Archive using: git clone git@bitbucket.org:atlassian/aui-archive.git

It seems to want to SSH into that server.

Colin Goudie Community Champion Nov 24, 2012

You hope? Have you tested it though?

When you say the git clone 'worked' to bitbucket, is that from the server or your dev machine?

I mean that I hope that it would work - it isn't working.

I'm doing everything from the server which has git installed (and Stash).

This widget could not be displayed.
Jason Hinch Atlassian Team Nov 25, 2012

Is the base URL for your server Stash server http://dev.domain.com/git? If not It looks like your clone URL is incorrect. It should be http://dev.domain.com/scm/KEY/ils.git

Hi Jason,

Yep, it is - that said, I've resolved it - git 1.8.0 isn't playing well on CentOS, so I've downgraded to 1.7.12 which does work

wow - thats obscure - but also good. Cool.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in Statuspage

What are your best incident management tips and stories? #HugOps

 👋Community members! Downtime happens. And great incident response takes a village. Teams like Support, Dev, SRE, Ops, IT, and Marketing have to come together to resolve the problem while keep...

64 views 2 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you