Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,703
Community Members
 
Community Events
176
Community Groups

Bamboo Spec Detection Error

I have installed Bamboo 6.5 on dev and Setup Webhook in our Github repo where the java spec is commited.

And now seeing following error in Bamboo

Processing Spec within Docker containerUnable to scan repository <<repo>> <<repoid>> for Bamboo Specs
com.atlassian.bamboo.repository.RepositoryException: Unable to scan repository <<repo>> <<repoid>> for Bamboo Specs
at com.atlassian.bamboo.configuration.external.RepositoryStoredSpecsServiceImpl.lambda$runSpecWithDocker$8(RepositoryStoredSpecsServiceImpl.java:687)
...
...
...
...
Caused by: com.spotify.docker.client.exceptions.DockerException: java.util.concurrent.ExceptionException: com.spotify.docker.client.shaded.javax.ws.rs.ProcessingException: com.spotify.docker.client.shaded.org.apache.http.conn.HttpHostConnectException:Connect to localhost:2375 [localhost/127.0.0.1, localhost/127.0.0.1, localhost/0:0:0:0:0:0:0:1] failed: Connection refused : connect

 

1 answer

1 accepted

0 votes
Answer accepted

Hi @Siddhant Gogri

Could you please share with us details about your installation? Is Bamboo inside a container? I reproduced this same behavior trying to run a docker container inside a docker container and that is not supported.

thanks

@Gabriel Ribeiro

No, I am not running Bamboo in a container. Nor is there any agent which has docker capabilities.

That is where I am confused, as to why do I get docker related error if there is no docker

@Siddhant Gogri

Did you select the "Process Bamboo Specs in Docker" at Cog icon>Overview>Security settings

@Gabriel Ribeiro Thanks

Didn't know about that option. It worked

It's worked, but there is another problem. Does it need network when scan linked repositories on bamboo. I'm the offline situation when scanning.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events