Bamboo SCP task not properly syncing directory structure

Greetings, I'm running an scp task, and on the first run of this task any file in the first sub-directory of the project is being copied to the root directory. This only happens with files from the first directory. If I re-deploy the release, it copies properly.

For example, if /application/foo/* exists, foo gets copied to /foo. If I re-deploy, it is copied to /application/foo as expected.

 

I'm using v5.11.0  of the plugin.

 

Thanks in advance.

1 answer

1 accepted

0 vote

@Dylan Redding your problem looks similar to https://jira.atlassian.com/browse/BAM-14439. If this is the same issue then please vote on it. If your problem is different then please create new bug report.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,561 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you