Bamboo SCP task not properly syncing directory structure

Greetings, I'm running an scp task, and on the first run of this task any file in the first sub-directory of the project is being copied to the root directory. This only happens with files from the first directory. If I re-deploy the release, it copies properly.

For example, if /application/foo/* exists, foo gets copied to /foo. If I re-deploy, it is copied to /application/foo as expected.

 

I'm using v5.11.0  of the plugin.

 

Thanks in advance.

1 answer

1 accepted

0 votes
Accepted answer

@Dylan Redding your problem looks similar to https://jira.atlassian.com/browse/BAM-14439. If this is the same issue then please vote on it. If your problem is different then please create new bug report.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Statuspage

Introducing Statuspage Getting Started guides! First up: What is Statuspage?

Over the next several weeks we'll be sharing some of our Getting Started guides here in the community. Throughout this series of posts, we'd love to hear from customers and non-customers ab...

190 views 4 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you