Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,331
Community Members
 
Community Events
176
Community Groups

Bamboo Performance is Very Bad

Hello,

I'm having serious performance issues with Bamboo. Page loads take upwards of 20 seconds. I have increased the max java memory heap to 2048MB but it isn't helping. Is there anything else I can try to increase performance?

I'm running Bamboo 6.2.2 on Windows Server 2012 R2.

4 answers

I am now running 6.3.0 and I'm still having issues. As a result we still haven't really used Bamboo. At this rate we might consider moving to jenkins.

Hi Frans,

We might need more information from you. Let me create a support ticket for you and followup from there.

0 votes

Hi Frans,

Are you seeing high CPU usage at the time you're observing poor performance? What backend database are you using?

Cheers,

Christian

Premier Support Engineer

Atlassian

CPU usage is minimal, between 1 and 5%. I'm using MySQL as a database back-end

0 votes

We'd need thread dumps to analyze this issue.It would be best if you contacted support.

I can't contact support due to having a starter license. I'm being redirected to the community.

0 votes

Are you running it standalone or is it deployed in Tomcat? 

I have installed the standalone.

I think there was some performance issues with standalone on Windows Server 2010 though.

Do you think you can try deploying it on Tomcat? To test out and see if the issue still persists? 

I'll try and see if I can get some results.

@Tayyab Bashir The link you provided is for deploying applications into tomcat using Bamboo. The supported platforms page also states that the only supported configuration is the bundled tomcat server. 

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events