Bamboo Maven builds stopped working. Plugin is installed and enabled.

Last week one of our Bamboo build plans mysteriously stopped working with the error:

Could not execute task 'Maven Build of XXX' no Plugin with key 'com.atlassian.bamboo.plugins.maven:task.builder.mvn3' is installed. 

This plan had been working successfully for months. The plugin is installed and is enabled.

The system plugin is called "Atlassian Bamboo Maven Tasks Plugin" key="com.atlassian.bamboo.plugins.maven" version 4.3.3 and it is enabled. The module "task.builder.mvn3" is enabled.

We have tried disabling and re-enabling the plugin. We have tried restarting Bamboo. We have tried creating a new plan that depends on Maven3 and it also fails.

1 answer

1 accepted

This widget could not be displayed.

The Bamboo agent machine, or one of the services on it, was not finding the correct JDK. We were able to fix the problem by pre-pending the JDK path to the PATH environment variable.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

197 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you