Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo Agent shutdown

We have 3 identical Vm agents in our bamboo setup, but one of them is misbehaving. It keeps shutting down. Any one have any ideas ?

INFO   | jvm 1    | 2012/07/23 15:10:23 | 2012-07-23 15:10:23,830 INFO [1-BAM::su-bamboopr02.homeoffice.myco.com::Agent:pool-3-thread-1] [BuildAgentControllerImpl] Agent 'su-bamboopr02.homeoffice.myco.com' ready to take build from queue...
STATUS | wrapper  | 2012/07/23 15:23:01 | TERM trapped.  Shutting down.
STATUS | wrapper  | 2012/07/23 15:23:03 | <-- Wrapper Stopped
STATUS | wrapper  | 2012/07/23 15:23:03 | --> Wrapper Started as Daemon
STATUS | wrapper  | 2012/07/23 15:23:04 | Launching a JVM...
INFO   | jvm 1    | 2012/07/23 15:23:04 | Wrapper (Version 3.2.3-atlassian-1) http://wrapper.tanukisoftware.org
INFO   | jvm 1    | 2012/07/23 15:23:04 |   Copyright 1999-2006 Tanuki Software, Inc.  All Rights Reserved.
INFO   | jvm 1    | 2012/07/23 15:23:04 | 
INFO   | jvm 1    | 2012/07/23 15:23:04 | WrapperSimpleApp: Unable to locate the class com.atlassian.bamboo.agent.bootstrap.AgentBootstrap: java.lang.UnsupportedClassVersionError: Bad version number in .class file
INFO   | jvm 1    | 2012/07/23 15:23:04 | 
INFO   | jvm 1    | 2012/07/23 15:23:04 | WrapperSimpleApp Usage:
INFO   | jvm 1    | 2012/07/23 15:23:04 |   java org.tanukisoftware.wrapper.WrapperSimpleApp {app_class} [app_arguments]
INFO   | jvm 1    | 2012/07/23 15:23:04 | 
INFO   | jvm 1    | 2012/07/23 15:23:04 | Where:
INFO   | jvm 1    | 2012/07/23 15:23:04 |   app_class:      The fully qualified class name of the application to run.
INFO   | jvm 1    | 2012/07/23 15:23:04 |   app_arguments:  The arguments that would normally be passed to the
INFO   | jvm 1    | 2012/07/23 15:23:04 |                   application.
STATUS | wrapper  | 2012/07/23 15:23:06 | <-- Wrapper Stopped

2 answers

1 accepted

1 vote
Answer accepted

It looks like you're starting the agent with an unsupported Java version. You need at least Java 6.

Yep. Someone tinkered with the JAVA_HOME and set it to Java 5.

Although, looking at the logs of earlier starts of the agent I do see this...

...Starting Agent Bootstrap using Java 1.6.0_16...

But I did update the JAVA_HOME env variable (linux) and it now reports...

... Starting Agent Bootstrap using Java 1.6.0_33 ...

Is the JAVA_HOME typically used ?

What does the TERM mean, is that some sort of time out ?

Deleted user Mar 24, 2016

Thanks Przemek and Greg, your question and answer solved a similar problem for us.

Have you guys followed up this official Bamboo jira ticket ?

BAM-17492

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

588 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you