Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo API: quicksearch only returns 12 results

When curling

https://host/rest/api/latest/quicksearch?searchTerm=blah

I'm getting back a json object with "size: 12" when there should be quite a few more than 12 results. Specifying max-results doesn't change anything, it will restrict the results to a number less than 12 but doesn't increase it to anything more than 12. 

 

Is there some other parameter I can pass that will force it to return more than 12, or is quicksearch just limited to 12? Does anyone know? Thanks!!

1 answer

1 vote
robhit Atlassian Team Nov 15, 2017

Hi Emmett,

 

How about trying this:

 

http://localhost:8085/rest/api/latest/quicksearch?searchTerm=plan&max-results=1

1. The above will give you max result =1

 

http://localhost:8085/rest/api/latest/quicksearch?searchTerm=plan&max-results

2. Will give you all

 

Let me know if it doesn't works

Thank you for your response!!

Option 2 still only returns 12, even with a searchTerm that should return hundreds of matches. It's like the max-results parameter is applied after the result set is returned from the search. The search returns 12, then it applies max-results to that 12. It will limit it if max-results is less than 12 but can't return more than 12 because the result set was already limited to 12 before max-results is even applied.

robhit Atlassian Team Nov 17, 2017

Hi Emmett,

 

Yes, you are right. It is limited to 12 only.

I believe it because of the fact that the result is paginated probably because if you do not have pagination you will face performance issues while getting all the data.

I also tried adding "&start-index=2" to see if I can loo into the next one:

http://localhost:8085/rest/api/latest/quicksearch?searchTerm=test&max-results=12&start-index=2

But, it seems it is also not giving the result.

Let me know if you can build a loop around this parameter.

I have the same problem. Any solutions to this?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

953 views 4 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you