Bamboo 5.12 compatibility with third-party add-ons and other Atlassian products

Hi there,

  1. I wonder if upgrading Bamboo from our current version 5.7.2 to the latest one (5.12) would require any respective updates for other Atlassian products our company is currently using, namely JIRA (current version 6.3.13), FishEye (3.4.3) and Confluence (5.8.4): if so, would you please be specific as to what minimum upgrade(s) will be necessary for each of the aforementioned products in order for them to be compatible with the latest Bamboo version 5.12?
  2. We currently have several third party add-ons (user-installed) - please see the entire list below - we want to continue to use: will upgrading Bamboo to its latest 5.12 version still make it possible for our company to keep them? Are all (or most) of the following add-ons currently supported in Bamboo 5.12 (or at least different versions of these):

        JMeter Aggregator (the most important for us to keep) (version 5.7.1) 

        PowerShell Task  (also very important) (version 1.1.9)

        Agent Utilities - Basic (version 1.0)
        Atlassian Universal Plugin Manager Plugin (version 2.20.4)

        Bamboo Build Times Plugin (version 1.0)

        bamboo-group-agent  (version 1.7)

        Bamboo Node.js Support (version 1.7)

        Bamboo System Banner (version 1.1)

 

Thank you in advance for your time and assistance.

 

Sergei Jerdetski
DevOps Engineer
Health Language

Wolters Kluwer Health
4600 S Syracuse St, Suite 1200
Denver, CO 80237

1 answer

0 vote

Hello @Sergei Jerdetski,

  1. You don't need to upgrade other Atlassian tools

    1. JMeter Aggregator was marked compatible with 5.12.1
    2. PowerShell Task is not managed by Atlassian
    3. Agent Utilities - Basic is not managed by Atlassian
    4. Atlassian UPM plugin 2.20.4 not tested, but Bamboo has bundled UPM plugin
    5. Bamboo Build Times Plugin is compatible
    6. bamboo-group-agent is not managed by Atlassian
    7. Bamboo Node.js Support is bundled with Bamboo 5.12, so you don't need to install it from Marketplace
    8. Bamboo System Banner is not managed by Atlassian

 

 

Powershell support is built into Bamboo so you might want to give it a try.

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,096 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot