Bamboo 4.2 upgrade error - No JVM found

I am trying to install Bamboo 4.2 on Windows Server 2008. I have downloaded atlassian-bamboo-4.2.0-windows-x32.exe, but when I attempt to run it an exception displays in a message box (image attached).

The log (also attached) appears to indicate that there is a problem with the java runtime, but JIRA is running on the same server but does not report any similar java-related problems.

(i4j_nlog.txt)

2 answers

1 accepted

This widget could not be displayed.

Hmm, that error message is wrong. You need Java 6 or above in order to run the installer.

Not sure about the exception message either - but Harry Chan has put me on the right track and after having installed the full JDK it installs OK. Thanks everyone

This widget could not be displayed.

Hi, as per Bamboo supported platforms, if you currently have the JRE, this will not work. You need the full JDK. Also please ensure that JAVA_HOME is set correctly in your environment variables. Note that this is not required for JIRA so might not be a problem.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

67 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you