Auto-Starting A Custom Elastic Image

Thanks to Przemek (Atlassian), I've successfully created a custom Elastic Image (AMI) which I can start through Bamboo and use to run my tests. All good.

However, what I'd like to know is how I can get Bamboo to automatically start that custom Image in order to run my tests after I have pushed changes to my BitBucket repo....? I can't seem to find any settings to force the use of my image rather than Bamboo's default image....?

Any ideas?

Thanks!

1 answer

1 accepted

0 votes
Accepted answer

You can disable the the default image(s). Or, make sure that the requirements on your Jobs (accessible via Job configuration) are met only by your custom image (add some custom capabilities to them in image configuration). Both methods are equally valid.

Perfect, thanks again Przemek

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Organizing your space just got easier - Page Tree Drag & Drop is here

Hi Community! I’m Elaine, Confluence Product Manager. You may have read my earlier post about page tree in space navigation sidebar. I'm excited to share another improvement that helps you organize ...

118 views 3 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you