Agent config for new tasks

Whenever I make a new change to the plan, add task or Artifact etc , the agent shows this message "no agent can build this job" even if the agent is configured to run the tasks. When I do a restart to the agent, it works again. Is there any other better way to do this? 

1 answer

0 votes

Hi Krishna,

Which type of task are you trying to execute? If you needed to install something in the agent server in order to use such task (e.g., Maven), you need to restart the agent so that environment variables can be picked. I am afraid configuring the Maven executable as agent capability is not enough.

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,072 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot