Agent - Updated Linux user's PATH, agent doesn't see it

I recently updated the linux user's (that runs the bamboo agent) PATH and when I try to run a build the agent fails to locate any executable in the new PATH, but when I run the process manually on the agent server (as the linux user that runs the bamboo agent), it works just fine.

Do I need to restart the agent since I updated the PATH?

4 answers

This widget could not be displayed.

Bouncing the agent resolved the issue.

This widget could not be displayed.

I also tried to add an executable to the Agent via the Admin console and that didn't help either.

This widget could not be displayed.

Since changing the PATH environment variable is related to changing a shell configuration file you need to restart the process in order to pick up the change.

This widget could not be displayed.

Hi Ed, 

Did you try to logout and login again from linux ?

P.S.: make sure when you login again the new path will be set up as expected.

 

Cheers, 

Renato

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

123 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you