Agent - Updated Linux user's PATH, agent doesn't see it

I recently updated the linux user's (that runs the bamboo agent) PATH and when I try to run a build the agent fails to locate any executable in the new PATH, but when I run the process manually on the agent server (as the linux user that runs the bamboo agent), it works just fine.

Do I need to restart the agent since I updated the PATH?

4 answers

Bouncing the agent resolved the issue.

I also tried to add an executable to the Agent via the Admin console and that didn't help either.

0 votes

Since changing the PATH environment variable is related to changing a shell configuration file you need to restart the process in order to pick up the change.

0 votes

Hi Ed, 

Did you try to logout and login again from linux ?

P.S.: make sure when you login again the new path will be set up as expected.

 

Cheers, 

Renato

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,066 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot