Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Trouble Connecting Jira Core 8.1 to MySQL 5.7.26



Spent two days trying to move Jira 8.1 server install to MySQL 5.7.26 but keep getting 'This MySQL instance is not properly configured...' error message.

Followed all the threads I could find online about configuring SSL but the error message persists. Now I want to connect without SSL which I tried several times initially.

When I use the tool I get the following message:

Wed May 15 15:24:14 BST 2019 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
Connection successful!

The error message after restarting the server and going through the setup wizard:

This MySQL instance is not properly configured. Please follow the documentation for MySQL 5.7+ setup.

Have been following this document to get the server connected to MySQL 5.7.26 (amongst others describing how to use SSL but not interested in that right now as both DB and server reside in close proximity)

The document above asks us to use config tool to configure the dbconfig.xml file then restart the server but when I do that I get sent back to the configuration wizard, basically going around in a loop! When I reach the wizard the My Own Database (recommended for production environments) option is chosen but keep getting the same error message (must have tried more that 30 times)

Here is the JDBC connection string as amended in dbconf.xml


Have inserted the following in mysql.conf.d/mysqld.cnf

# Jira

After Trying SSL connection and getting the exact same error I'm no longer pursuing the SSL route for the reasons mentioned above and the sake of creating a simpler environment.


We're using mysql-connector-java-5.1.47


Deleted user Nov 22, 2019

@Paul Alain Did you solve your problem? I have the exact same situation.

Here is the answer


You need to add "useSSL=false&amp;" this parameters in the dbconfig file.

Example: <url>jdbc:mysql://localhost:3003/jiradatabase?useUnicode=true&amp;"---ADD HERE---"characterEncoding=UTF8&amp;sessionVariables=default_storage_engine=InnoDB</url>

The line that I was able to get - with Jira 8.7.1, and MySQL 5.7.29 to remove the SSL warning was:   <url>jdbc:mysql://<IP Address of DB server>:3306/jiradb?useUnicode=true&amp;autoReconnect=true&amp;useSSL=false&amp;verifyServerCertificate=false&amp;characterEncoding=UTF8&amp;sessionVariables=default_storage_engine=InnoDB</url>

The key was the correct use of &amp and ";" placements - otherwise Jira would hang on the start and not proceed.    In my case - internal systems and no need to connect to our database via SSL and this removed all the warnings from my catalina.out file.

I think you need to replace & with &amp;


Log in or Sign up to comment
Community showcase
Asked in Atlassian Cloud Migration

AMA with Chris Clarke: Head of Product, Migration Journey

Happy  Migrations Month ! If you haven’t heard, this January we’re hosting exclusive events, giving away cloudies, and sharing helpful resources as part of our #CountdownToCloud celebration. H...

1,244 views 10 17
View question

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you