It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Failure on import of board on migrating a project

We are evaluating migration of our Server Jira installation to the cloud.

On one of the projects, migration fails on importing the Board of the project.

Error on the log is as shown below:

2020-05-26 18:59:19.252 ERROR KP project-import We couldn't import Board 'Kickbox board'. Reason: query: The value '1.40.0' does not exist for the field 'fixVersion'.. This caused 47341 other items to fail.

 

The value '1.40.0' is used on several issues as Fix Version value, also the swimlanes looks like working correctly in the Server installation.

1 answer

1 accepted

0 votes
Answer accepted

Hi @Walter-42 

The first thing I would check is the exact spelling of 1.40.0 in all instances as it is very easy to have something which looks like that but is actually different. Versions are just a text string and can be different without looking so.... 

1.40.0

1.40.O

1.4O.O

1.4O.0 
may all appear the same but are very different with O and 0.  But the one that often catches people out is where there is a trailing space. 

1.40.0<space>


Once you have checked all these then I would make sure with a single issue import that the layout of the item in your import file does not contain any spurious characters (tabs, non-printing spaces, etc) 

Hope this helps you to troubleshoot a bit further. 

 

Phill

It will be kind of difficult to import a single issue, as we are using the "Jira Cloud Migration Assistant" from the available app list in jira, which only supports migration of full projects.

The swimlanes are configured on the board to be based on queries, where the Fixversion is defined. The editor there is automatically adding a space after the number, when entering, as it is expecting something like AND/OR/etc.. Strange thing is that the swimlanes on the board do function correctly with the defined queries.

 

For now, removed the trailing space, and trying again.. And know what? It works.. But, not because of my change.. There was an update on the app.. As, before updating the board, a copy was made.. And, forgot to update that one.. Arrghhh. Thanks anyway...Screenshot 2020-05-27 at 17.17.23.png

Like Phill Fox likes this

Hi @Walter-42 
Well I am glad you have solved your problem it is amazing how often we can come across things that work when tried just one more time.  Also do not expect consistency is something I learnt a long time ago with software written by different folk. One might remember to trim a string to remove trailing spaces whilst another might not and as the testers might also be different people/time they may not even pick up this subtle difference. 

 

Phill

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Atlassian Cloud Migration

We want to hear from you about the server to cloud migration experience!

Hello! We are developing new set of features for the Confluence Cloud Migration Assistant and Jira Cloud Migration Assistant and we’d like to invite our valued Atlassian Community members to help p...

442 views 0 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you