Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Sync from Okta excluded one group member

Darryl St_ Pierre
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jan 06, 2020

We turned on User Provisioning this morning in Okta. We created a push group where the Active Directory (source) group has 7 members.

The group successfully provisioned to Atlassian Access, however only 6 of the 7 members were included in the group.

The account that wasn't included existed in the Directory in Atlassian prior to provisioning. It was enabled but had no product access defined.

I setup "no-email" invitations for the other 6 accounts prior to provisioning, and they all successfully provisioned, e.g. -their full names now appear instead of just their email address.

There are no error indications in the Audit log in Access, nor in Okta. In fact, Okta indicates 7 users were provisioned.

I tried enabling product access on the problem account and forcing a sync from Okta, but the group remains at 6 members.

Before I move on to Support I thought I would try here for suggestions or info.

Darryl

2 answers

1 accepted

2 votes
Answer accepted
Ramon M
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jan 07, 2020

Hey Darryl, 

 

In Okta, an account may not be properly synced into Atlassian if it has been assigned to the Atlassian Cloud app before provisioning was configured. 

Have you tried to re-assign the user to the app in Okta? Check if there was a direct assignment for the user to the app in Okta and remove it. Remove and re-add the account to the pushed group.

 

Regards,

Ramon

Darryl St_ Pierre
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jan 08, 2020

Thanks for the response @Ramon Macalinao . I'm currently waiting on others to do the work in Okta, but will respond with results when we're done.

Darryl

Darryl St_ Pierre
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jan 15, 2020

This was the answer. I appreciate the assist @Ramon Macalinao !

Ramon M
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jan 15, 2020

Awesome, glad to hear it worked. :)

We've recently released Jira User Sync/Provisioning plugin which provisioned all Users and groups from Cloud Identity provider(Okta) to Jira.

 

You can take a look: https://marketplace.atlassian.com/apps/1222000/user-group-sync-for-jira?hosting=server&tab=overview

 

Here is the setup steps: https://plugins.miniorange.com/user-and-group-sync-user-provisioning-okta 

 

Thanks,

Prakash

Plugin is for server only, please note that in future posts.

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events