Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

cannot be installed on this Cloud instance

I am developing an Atlassian connect addon using Atlassian connect express, and I am getting the most unhelpful error message. "https://<redacted>/hello-world cannot be installed on this Cloud instance."

Can I get some steps for how I would go about troubleshooting this?

I dug through the code from the example apps and I am not seeing anything obviously wrong. I can access the the connect file just fine at "https://<redacted>/hello-world/atlassian-connect.json" and it is publicly accessible.

Thanks.

Edit: I am trying to install this to JIRA.

Here is my descriptor:

{
	"key": "&lt;redacted&gt;-hello-world",
	"name": "&lt;redacted&gt; Hello World",
	"description": "Hello, World!",
	"vendor": {
		"name": "&lt;redacted&gt;",
		"url": "http://&lt;redacted&gt;.com"
	},
	"baseUrl": "https://&lt;redacted&gt;/hello-world",
	"links": {
	    "self": "https://&lt;redacted&gt;/hello-world/atlassian-connect.json",
	    "homepage": "https://&lt;redacted&gt;/hello-world/atlassian-connect.json"
	},
	"authentication": {
        "type": "jwt"
    },
    "lifecycle": {
        "installed": "/installed"
    },
	"scopes": [
		"READ"
	],
	"modules": {
		"generalPages": [
			{
				"key": "hello-world-page-jira",
				"location": "system.top.navigation.bar",
				"name": {
					"value": "Hello World"
				},
				"url": "/hello-world",
				"conditions": [ {
					"condition": "user_is_logged_in"
				} ]
			}
		]
	}
}

9 answers

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

1 vote
Answer accepted
Dave Atlassian Team Jun 07, 2016

Just want to make sure that you are in fact, passing in the url "https://<redacted>/hello-world/atlassian-connect.json" to upm to obtain your descriptor from?

If you are using "https://<redacted>/hello-world", the default ACE project (setup via "atlas-connect") will:

  1. Supply an html page that requires authentication on requests to "/hello-world",
  2. Redirect "/" to "/atlassian-connect.json"

I have just replicated this warning by supplying HTML instead of JSON, but there can be other ways to get that warning message unfortunately 

1 vote
wadey Atlassian Team Jun 07, 2016

Hi @Alex Kinnee, this error message is returned by the Plugin Manager - within your Atlassian Cloud product - when side-loading installation of an add-on is forbidden. 

For Atlassian products that constitute your development environment you can enable "development mode", for which you would follow the instructions here: https://developer.atlassian.com/static/connect/docs/latest/guides/development-setup.html#enable-development-mode

For Atlassian products that also represent your production instance of JIRA (in your case, judging by your tags) we recommend you set up a private listing of your development add-on on Atlassian Marketplace: https://developer.atlassian.com/static/connect/docs/latest/developing/cloud-installation.html

Hope that helps -nick wade
Head of Ecosystem Business 

I do have development mode turned on. Thanks.

wadey Atlassian Team Jun 08, 2016

Glad the dev team got you sorted out man! 

@Eric I highly recommend that you open your own question and link back to this one. Your circumstances might be different.

I realize this question has an accepted answer but....... I am running into the exact same symptoms as described above: I have a very simple ACE add-on that refuses to install when working through UPM.  If I configure the credentials.json file, then the add-on gets installed/uninstalled as it should be.  I'd like to be able to install the add-on on multiple instances without have to configure credentials for each instance it is being used on.  Any ideas on what is going on here?

0 votes
Dave Atlassian Team Jun 08, 2016

Awesome laugh done smile

@Dave Haden: I believe that solved it. Please add it as an answer so I can accept it. Thanks!

So I should paste the URL directly to the atlassian-connect.json file?

0 votes
Dave Atlassian Team Jun 07, 2016

Also with using ACE, I would recommend using the auto installation feature, by creating a "credentials.json" file like the one in the template, and adding this file to your .gitignore

Can you share your descriptor with us and the Atlassian product that you are trying to install it into? Cheers!

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

TAGS
Community showcase
Published in Marketplace Apps & Integrations

Get ready for 🍻🍂 Apptoberfest🍂🍻!

Starting October 1, we’ve got a month of app-related fun in store here in the Atlassian Community. So fasten your seatbelts and dust off your lederhosen, because we’re bringing you … 🥁🥁🥁 Apptoberf...

151 views 3 9
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you