It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Too many simultaneous connections Gmail error

I use JETI plugin and I have this error

=====> atlassian-jira-incoming-mail.log <=====

2014-10-20 16:12:17,783 ERROR [issues.jira@movile.com] QuartzScheduler_Worker-0 ServiceRunner APT - Issues APT - Issues[10520]: Error connecting to host 'imap.gmail.com' as user 'issues.jira@movile.com' via protocol 'imaps': javax.mail.AuthenticationFailedException: [ALERT] Too many simultaneous connections. (Failure)
javax.mail.AuthenticationFailedException: [ALERT] Too many simultaneous connections. (Failure)
 at com.sun.mail.imap.IMAPStore.protocolConnect(IMAPStore.java:665)
 at javax.mail.Service.connect(Service.java:295)
 at com.atlassian.jira.service.services.mail.MailFetcherService$MessageProviderImpl.getAndProcessMail(MailFetcherService.java:221)
 at com.atlassian.jira.service.services.mail.MailFetcherService.runImpl(MailFetcherService.java:388)
 at com.atlassian.jira.service.services.file.AbstractMessageHandlingService.run(AbstractMessageHandlingService.java:257)
 at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:61)
 at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:48)
 at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
 at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520) 

 

I have already seen that Gmail has a 15 connection limit on IMAP servers. Is there a way to solve this problem? And, case not, will i lose information or does JIRA retry creating tickets?

2 answers

0 votes

Hi, 

I have not seen this kind of problem with JETI so far, but I do believe it is not related to JETI.

IMAP email connections to email accounts are managed by JIRA not by JETI, as the stacktrace reflects it.

By default Mail Fetcher Service is connecting every minute for new emails. 

Is the connection to gmail.com fast? Slow network or stuck connections may also cause this problem I think.

 

It may be enough to increase the period, the service is checking emails. Perhaps increasing it from 1 minute to 3 or 5 is enough.

You can increase this in JIRA Administration / Services / Mail Fetcher Service.

0 votes

There is also a Delay parameter in the Mail Handler in Administration / Incoming Mails. You may wan to try to increase it as well.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase

Friday Fun: What's your best vacation planning hack?

Let's face it, work can be challenging but fulfilling, especially when you enjoy the challenges thrown at you.  However for me, nothing compares to going on vacation (or holiday as some of you m...

466 views 26 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you