Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,300,812
Community Members
 
Community Events
165
Community Groups

JIRA webhook does not send triggers

Hello,

I created a webhook in JIRA to get triggers to my external application, whenever Issues are created/updated/deleted. But application is not triggered even when Issues are created or modified. sad

Is there a way to check/debug if the webhook is actually sending triggers? Any suggestions would be helpful.

Thanks in advance

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

This will only work if you have access to the log files.  If you do, then you can debug the webhook triggers.
If you go to Admin --> System --> Logging and Profiling, you can "Configure logging level for another package".  Add this entry –  com.atlassian.webhooks.plugin.PublishTaskFactoryImpl and set to Debug.  This will only log an entry when the webhook has been triggered, so if you don't see any entries, the webhook is not triggering.

Thank you, Chris! 

That helped me solve my issue.

TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you