Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to resolve the plugins failed to load error?

Hi,

I've set up my development environment to start working on some plugins, but the atlas-run command fails to load JIRA with this error:

JIRA Startup Failed

You cannot access JIRA at present. Look at the table below to identify the reasons

The following plugins are required by JIRA, but have not been started:

  • Gadget Directory Plugin (com.atlassian.gadgets.directory)
  • Atlassian JIRA - Plugins - Project Config Plugin (com.atlassian.jira.jira-project-config-plugin)
  • Atlassian OAuth Admin Plugin (com.atlassian.oauth.admin)
  • Embedded Gadgets Plugin (com.atlassian.gadgets.embedded)
  • Atlassian JIRA - Plugins - Shared Application Access Layer (SAL) Plugin (com.atlassian.sal.jira)
  • Gadget Dashboard Plugin (com.atlassian.gadgets.dashboard)
  • Atlassian JIRA - Plugins - Look And Feel Logo Upload Plugin (com.atlassian.jira.lookandfeel)
  • Atlassian JIRA - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)
  • Atlassian REST - Module Types (com.atlassian.plugins.rest.atlassian-rest-module)
  • FishEye Plugin (com.atlassian.jirafisheyeplugin)
  • Gadget Spec Publisher Plugin (com.atlassian.gadgets.publisher)
  • Atlassian JIRA - Plugins - REST Plugin (com.atlassian.jira.rest)
  • Atlassian OAuth Service Provider Plugin (com.atlassian.oauth.serviceprovider)
  • Opensocial Plugin (com.atlassian.gadgets.opensocial)

Some investigation lead to https://jira.atlassian.com/browse/JRA-22633, but it doesn't give any solution to resolve the issue. Is it possible to increase the timeout on these plugins to give JIRA more time to load? If so, where can it be done? Or is the only solution to work on a more powerful machine?

10 answers

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

Not sure if you've already solved this and just didn't let us know, but I just had this same issue and found that apparently JIRA doesn't work properly on Java 1.7. If you downgrade to 1.6 everything runs smoothly.

J Thomas, here it is the documentation you asked for:

https://confluence.atlassian.com/display/JIRAKB/JIRA+does+not+Start+Due+to+Disabled+Bundled+Plugin

Check your Java version too, it has to be 1.6

Any chance of getting this fixed so it works with Java 1.7, it is a released version of Java. I really do not want to have a Server just to run Jira on Java 1.6

That's a much bigger question than just a small handful of plugins

Jira does not work properly with Java 1.7 yet. I understand Atlassian have it on the to-do list, but I've no idea how close.

You need to use 1.6 for the foreseeable future, and probably assume that you'll need to upgrade to Jira 5.something-higher-than-2 to use Java 1.7

In my job we have found that Java 1.7 and Tomcat 7 have a additional Servlet abstract methods that need to be created for them to work properly.

Another big one is request.getParameterMap().keySet() now returns Objects instead of Strings

Just going to be a pain to make a VM that is different from everything else we have...

Thanks for the answer

I really don't think you're going to have to wait for a vastly interminable time - it's very much in Atlassian's interest to get it working with Java 1.7 and they're definitely working on it.

Bear in mind we live in a world where some people still use and expect support for Internet Explorer, so Atlassian are still way ahead of a lot of vendors. (Oh, sorry, yes, I suppose I should have said IE7. Not that 8 and 9 are huge improvements, still way behind all the real browsers)

If the logs suggest you're timing out, you can add the following to the JIRA Java Options in the Registry:

-Datlassian.plugins.enable.wait=300

We turned off our Anti-Virus SW, added the 5 min. wait (above), and have had no issues with the plug-ins loading.

Try turning off your anti-virus software

Using Java 1.6 instead of 1.7 solved the issue for me

I just encountered this issue tyring to get the custom importer sample plugin working, I am on "1.7.0_25" and it isn't easy for me to switch back to Java 6, does anyone know if this is still an issue with Java 7?

The problem gone after I installed java jdk1.6.0_32, java 1.7.0_04 couse this problem. I am using Ubuntu 10.04

This seems like bundled JIRA plugins got disabled and caused JIRA failed to start. Here is the related KB that could help you to solve the problem:

- http://confluence.atlassian.com/display/JIRAKB/JIRA+Fails+to+Start+Due+to+Bundled+Plugin+is+Disabled

Hope it helps!

Unfortunately the KB article has been deleted. Can you recall how it suggested you solve this problem?

0 votes

Depends on why they aren't loading in time. You should check the log file from startup to failure for errors - that could tell you what is going wrong (throwing timeout or hardware at it if the error is "something is misconfigured" isn't going to help you). If the logs are totally clean, then yes, you may need more resources - what are you running it on?

Ok, seems I have a bunch of OsgiContainerException's due to bundle constraints errors. I'll look into resolving them.

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you