Error in extracting the author information while migrating project svn to bitbucket.

Hi,

I am new to bitbucket. I want to Migrate my project from SVN to bitbucket. I am taking help from following link: https://www.atlassian.com/git/tutorials/svn-to-git-prepping-your-team-migration.

I am having problem in prepare stage. While creating authors file, I am running following command:

java -jar svn-migration-scripts.jar authors <My SVN repository-url> [<My SVN username> [<My SVN password>]].

But I am getting followng error:

svn: E220001: Item is not readable
Could not communicate with Subversion: check the URL of the repository, the username and the password are all valid
Error written to /tmp/error-script-1554981439875119661.txt

And error-script-errornumber.txt contains

javax.xml.stream.XMLStreamException: ParseError at [row,col]:[3,1]
Message: XML document structures must start and end within the same entity.
at com.sun.org.apache.xerces.internal.impl.XMLStreamReaderImpl.next(XMLStreamReaderImpl.java:596)
at scales.xml.XmlPull$class.pumpEvent(PullIterator.scala:167)
at scales.xml.XmlPulls$$anon$1.pumpEvent(XmlPull.scala:118)
at scales.xml.XmlPull$class.next(PullIterator.scala:149)
at scales.xml.XmlPulls$$anon$1.next(XmlPull.scala:118)
at scales.xml.XmlPulls$$anon$1.next(XmlPull.scala:118)
at scales.utils.IterateeImplicits$$anon$2.apply(Iteratees.scala:35)
at scales.utils.IterateeImplicits$$anon$2.apply(Iteratees.scala:29)
at scalaz.IterV$class.apply(Iteratee.scala:14)
at scalaz.IterV$Cont$$anon$2.apply(Iteratee.scala:55)
at scales.utils.Iteratees$ResumableIterIterator.<init>(Iteratees.scala:198)
at scales.utils.Iteratees$class.withIter(Iteratees.scala:216)
at scales.utils.package$.withIter(package.scala:3)
at scales.xml.PullIteratees$Iterate.<init>(PullIteratees.scala:178)
at scales.xml.PullIteratees$class.iterate(PullIteratees.scala:202)
at scales.xml.package$.iterate(package.scala:3)
at scales.xml.PullIteratees$class.iterate(PullIteratees.scala:172)
at scales.xml.package$.iterate(package.scala:3)
at com.atlassian.svn2git.Authors$.parseUserXml(Authors.scala:151)
at com.atlassian.svn2git.Authors$$anonfun$5.apply(Authors.scala:137)
at com.atlassian.svn2git.Authors$$anonfun$5.apply(Authors.scala:136)
at scala.sys.process.ProcessBuilderImpl$Simple$$anonfun$3.apply$mcV$sp(ProcessBuilderImpl.scala:73)
at scala.sys.process.ProcessImpl$Spawn$$anon$1.run(ProcessImpl.scala:22)


I am not sure what I am doing wrong. Kindly help me!


2 answers

Same here :|... and - which is worse - having a look into https://bitbucket.org/atlassian/svn-migration-scripts/issues?status=new&status=open ... it seems Atlassian has given up any support to it, nor?

 

@Rohan Suroshi: Have you ever opened a bug to this - I mean not in their Bitbucket server issues but directly at their support side?

Hey @Ingo-Stefan Schilling, I solved the issue couple of weeks back but forgot to post the answer. We have to make changes in svnserve.conf (and in related authz and passw files if necessary). You can follow this link: http://svnbook.red-bean.com/en/1.7/svn.serverconfig.pathbasedauthz.html or any other svn setup tutorial for instructions. One mistake I was doing that I was trying to setup new svn server on my local machine and give read permission, which is wrong. Our project administrator gave read permission to my project and other problem solved.

I have the same problem.. did you ever find an answer? It seems to be ignoring the svn credentials. I can connect to svn on the command line, but I get a credentials error when I use the tool

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 6 hours ago in United States

Atlassian acquires AgileCraft

         Good Day, Bad bad traffic, not sure why!!!! 1/2 hour commute took me 2 hours today 🤯 What helped me is that I kept browsing LinkedIn until...

29 views 1 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you