It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Creating JSD customer request via REST API fails on Server but works on Cloud

Hi,

I have some code that attempts to create a JIRA Service Desk customer request via the REST API. I am attempting to run it against a Server instance but have tried it against an identically configured Cloud one (the Server instance is actually a restored version of the Cloud one).

The code executes successfully against the Cloud one and the service request is created but against the Server I get the following error message (first 10 lines):

Unrecognized field "serviceDeskId" (Class com.atlassian.servicedesk.api.rest.dto.domain.request.RequestCreateDTO), not marked as ignorable
at [Source: org.apache.catalina.connector.CoyoteInputStream@7ed11eb5; line: 2, column: 23] (through reference chain: com.atlassian.servicedesk.api.rest.dto.domain.request.RequestCreateDTO["serviceDeskId"])</message><stack-trace>org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized field "serviceDeskId" (Class com.atlassian.servicedesk.api.rest.dto.domain.request.RequestCreateDTO), not marked as ignorable
at [Source: org.apache.catalina.connector.CoyoteInputStream@7ed11eb5; line: 2, column: 23] (through reference chain: com.atlassian.servicedesk.api.rest.dto.domain.request.RequestCreateDTO["serviceDeskId"])
at org.codehaus.jackson.map.exc.UnrecognizedPropertyException.from(UnrecognizedPropertyException.java:53)
at org.codehaus.jackson.map.deser.StdDeserializationContext.unknownFieldException(StdDeserializationContext.java:267)
at org.codehaus.jackson.map.deser.std.StdDeserializer.reportUnknownProperty(StdDeserializer.java:649)
at org.codehaus.jackson.map.deser.std.StdDeserializer.handleUnknownProperty(StdDeserializer.java:635)
at org.codehaus.jackson.map.deser.BeanDeserializer.handleUnknownProperty(BeanDeserializer.java:1355)
at org.codehaus.jackson.map.deser.BeanDeserializer.deserializeFromObject(BeanDeserializer.java:717)
at org.codehaus.jackson.map.deser.BeanDeserializer.deserialize(BeanDeserializer.java:580)

I have checked that the serviceDeskId and requestTypeId are the same on both Server and Cloud. 

The version of JIRA installed on Server is shown as: v7.1.9#71013-sha1:1aa0586

How do I make this work on Server?

Regards, Dom.

2 answers

1 vote
Gerry Tan Atlassian Team Aug 24, 2016

The create customer request endpoint was still marked as experimental in JSD version 3.1.x, and there are changes we made in cloud and 3.2.x or above, most notably the field "serviceDesk" is changed into "serviceDeskId". Please double check what JSD version you have in server.

For reference:

 

Hi Gerry,

Thank you for your answer. We have updated to JSD 3.2.0 following the instructions in the release notes but are now having a series of problems associated with permissions. 

Firstly, the REST API endpoint is now returning a "403 - Forbidden" response for all calls. With exactly the same user account prior to upgrading we were at least able to access the endpoint even though this specific call did not complete successfully. 

Secondly, when we open the project settings page we get the pictured error for the following sections:

  • Request types
  • Request security
  • Portal settings
  • Satisfaction settings
  • Email requests
  • Knowledge base
  • SLAs
  • Automation

ScreenClip.png

We have not changed the permissions settings between upgrading. We have tried a number of different users which have all definitely been able to view these pages prior to the update. 

To further investigate the issue we have created a brand new JSD project and we have exactly the same "snap!" messages for the freshly created project. 

Any advice would be very helpful. At the moment we can not administer our JSD projects. 

Regards, Dom.

 

Gerry Tan Atlassian Team Aug 25, 2016

Dominic I suspect that's a permission / licensing problem. I couldn't think why upgrading from 3.1 and 3.2 would result in this. I'd recommend you check the license / permission for the user as documented here: https://confluence.atlassian.com/adminjiraserver072/assign-users-to-groups-project-roles-and-applications-828787671.html and contact our support team if that still doesn't resolve your problem: https://support.atlassian.com/customer/servicedesk-portal

Hi Gerry, 

Thanks for your reply. We have rechecked the permissions (that was our first though too) but everything seems correct. Also, the licenses for JIRA and JSD seem to be valid as well. 

We have raised a support request. 

Thanks again for your help.

Regards, Dom.

Any updates on this issue? Encountering similar problem.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Jira

We want to hear from you! How do you use Slack and Atlassian together?

Hi Everyone! My name is Mina and I am on Atlassian’s Ecosystems Marketing team. Our team is focused on our technology partnerships and marketplace apps. One of Atlassian’s partners is Slack, who ...

85 views 1 5
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you