Build error with Eclipse. Missing artifact com.sun:tools:jar1.5.0

Hello

I'm following the guilde to get my skeleton plugin working and whenever I run atlas-create-jira-plugin I get this error.

[ERROR] BUILD ERROR
[INFO]-----------------------------------
[INFO] Failed to resolve artifact.

Missing:
-----------
1> com.sun:tools:jar:1.5.0
...
[INFO]--------------

I've set eclipse to run against the JDK instead of the JRE already, I've tried replacing the tools-1.5.0 inside \repository\com\sun\tools\1.5.0 with the one supplied in the JDK, I ran the command given and it was successful but it seems to have installed it to \.m2\repository\com\sun\tools\1.5.0

Any ideas what else to try?

1 answer

1 accepted

2 votes
Accepted answer
Joe Clark Atlassian Team Oct 04, 2011

You need to make sure that maven and the atlassian plugin sdk are looking up the correct JDK installed on your system (in addition to eclipse), rather than a JRE.

What is your $JAVA_HOME environment variable pointing to? Make sure it's set to a valid JDK directory.

That was it. I changed the eclipse settings to use the JDK but didn't think to check the JAVA_HOME variable.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 7 hours ago in United States

Topic Tuesday, now on Thursday! :-P

Happy Thursday everyone! This is usually a Tuesday thing but I've been crazy busy.  I finally had a moment to breath and so here we are. Atlassian has several tools and features to help users ...

8 views 0 0
View post

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you