Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,890
Community Members
 
Community Events
176
Community Groups

a custom field selection isnt reflected in advanced roadmaps

Hi,

an issue is set with a custom field of a user picker type, called business owner.

a value is selected for that field, view the issue view.

when i go and observe the issue in the advanced roadmaps, the field appears as empty. 

any ideas why?

 

Thanks

Ben

1 answer

0 votes

The UI can be a bit tricky, but you have to add it into the plan for you to be able to expose/see it.  There are 2 steps to make it available. 



chrome_2022-01-17_11-47-32.pngchrome_2022-01-17_11-48-13.png

In the 2nd image, there is a button in the top right.  That's the step my team misses most often.

Thanks @Chris Buzon but that is not the case. i've added the field so it can be added in the plan. i can add the field itself, but the value of it, which was set on the issue, is not appearing when i view the plan.  kindly2022-01-17 22_36_33-Ben's test - Advanced Roadmaps - JIRA.png see the attached image:

Ah, ok - I see.  So, you've added the field - but you will have to do a review of any existing changes (I see the blue button in your screenshot, top right).  If you a) discard or b)push those changes then this plan view will refresh and you should see the values in the field you've selected.

I just tried this on a plan I have and first had the same problem - my field with user-selection was visible, but none of the names were there, but after discarding a change (they were just removing tickets from my plan in my case), it refreshed the plan and the values of the field appeared.

Plans is not a real time preview, and when you have changes in queue it doesn't seem to poll all the fields in the selection. I'm not sure why that is, but it appears that you can fix it by making a new plan or dealing with the reviewable changes in your plan.

thanks @Chris Buzon  i created a plan from scratch with the issue, so no changes to review. the field's value still doesnt show in the plan. i tried to make another change and discard it, that too didnt help. 

That's a different method - I tried making a new plan, and I also didn't see the values.  To fix that I just saved the view ("Save this View" button), and then refreshed the page with F5.  After the refresh the values are visible, but they were not until after doing both the save and the refresh.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events