Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,341
Community Members
 
Community Events
176
Community Groups

Some Epics from Jira Project not visible in Plans

I've set up an a plan using a filter, and one of 3 Epics are not appearing.

I've tried the filter with this:

parentEpic in (BIZ-39, BIZ-1 BIZ-26) order by created DESC

and this:

parentEpic in (BIZ-39, BIZ-26) or parentEpic = "BIZ-1" order by created DESC

But BIZ-1 Epic and child tickets do not appear in Plan, while the other 2 appear fine.

The Filter itself returns the correct result set.

Anyone know what is going on?

3 answers

1 accepted

2 votes
Answer accepted

Hi @Martin Rait

Your first JQL is missing a comma after BIZ-1, but as you mentioned when you look at the filter itself it returns the correct set of issues, so I'm assuming that might just be a transcription error here? If so, it's likely that your BIZ-1 Epic is being captured by some sort of exclusion rule.

By default, a newly created plan will exclude issues that have been in the "Done" status for more than 30 days, so if your BIZ-1 Epic was moved to Done more than a month ago that could be why it's not showing up.

Otherwise, you can check any other exclusion rules by clicking the three dot menu next to your plan name, selecting "Configure"  and then "Exclusion Rules". Comparing the rules configured here to your BIZ-1 Epic may reveal why it's being excluded.

Hopefully this helps resolve the issues you're having, but let me know if you're still having trouble and we can certainly dig into this a little deeper!

Cheers,

Daniel

missing comma is a typo for mine typing here.

The 30 day thing is annoying and appears to be what is going on - do many different areas to configure things. Resolved that and found it hiding releases as well.

We needed this to be a full client facing plan - so all work done needed to be present.

Thanks

Like Daniel Capizzi likes this

No problem Martin - I'm glad that resolved the issue for you.

I can definitely understand that Advanced Roadmaps can be a bit of a beast to get familiar with! We're always trying to improve so I'll pass your feedback on to the team, and do always feel free to reach out here for any further questions you have or at Atlassian Support for more in-depth support.

1 vote

@Martin Rait -

Hi Martin:

I am glad that you found the issue.  So you just need to ensure you configure the "Exclusion Rule" to fit your needs. 

As also mentioned in my previous answer, the "Exclusion Rule" often is the problem because it is always defaults to 30 days setting when a plan is created.

Lastly, you should also adjusted it so your plan only display most relevant issues instead of everything.  It is because there can be performance impacts + too many issues are being displayed to allow your users to focus on.

If my advise also helped you.  Please click on Accept Answer when you have a chance.

Best, Joseph

1 vote

@Martin Rait -

Welcome to the community.  When you referring "Filter" are you referring to the issue source from the plan's configuration UI?

If not, then you need to check your issue source setup and ensure the source contains those missing EPICs.  

If yes, then you need to check the "Exclusion Rules" area in the plan's configuration UI to determine if there are any rule setup which excluded your missing Epics.  Lastly, you should also check the "Removed Issues" area in the plan's configuration to see if those issues are displayed, if you sees them there, you can click on "Re-include" button to bring those issues back into your plan.

Hope this helps.

Best, Joseph Chung Yin

Jira/JSM Functional Lead, Global Infrastructure Applications Team

Viasat Inc.

@Joseph Chung Yin Could you please help me find the "Exclusion Rules" section and the "Removed Issues" section? I am not able to find these in the configuration section.

@Indranil Ghosh -

Welcome to the community.  You will need to access your plan "Plan settings" and then select the "Configure" option.  In the configuration UI, you will find what you are asking for.

2022-12-12_9-06-27.png

2022-12-12_9-06-40.png

Best, Joseph

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events