Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,578
Community Members
 
Community Events
176
Community Groups

Restricting issue types by default in the Settings does not work

I created new issue type and added default restrictions to  certain roles in the settings. 

I expect the following: 

"For new issues, only allow these roles to view them by default."
But when I create new issue, it is created with No restrictions
Am I doing something wrong? How can I enforce this setting? 

1 answer

1 accepted

0 votes
Answer accepted
Vishwas Rising Star Jan 17, 2022

Hey @Mikhail Ponomarev 

Welcome to Atlassian Community !!

When you mean restrict issue type, how did you achieve this. Did you write any script in scriptrunner ?

Or you are referring to Issue security level ? Could you explain more ?

Based on these we can guide.

 

Regards,

Vishwas

@Vishwas , no I am not using any script. I am using Settings only. So when I am in Project settings I simply click LOCK sign to make default restrictions. According to "Learn more" it shall work.

See screenshot:

Screenshot 2022-01-17 at 18.17.07.png

But when I create an issue of this type after settings are on, the created issue is not restricted. 

Vishwas Rising Star Jan 17, 2022

Hi @Mikhail Ponomarev 

Got it, its Team Managed Project in Jira and you are using restrict issue type to users.

I did one round of testing it's working as they have mentioned in the doc.

So I configured for Issue type "Task" to only be visible to "Administrator"

While creating it showed me this by default "Restrict to" was filled to "Administrators"

TPM_Restrict_Issue_2.png

After issue created I switched to a user with member role in that project and i got this message.

TPM_Restrict_Issue.png

 

Please check if your red lock symbol is on and check with one of the users who are not in "Members" role.

 

Regards,

Vishwas

@Vishwas thanks, but I see that on your screenshot you create issue by using big button Create on the top. I tried it and it works.

But if I create and issue on the board by using "+Create issue" then it doesn't work:

We almost always create issues on the board. Also not sure if the issue produced by Jira Automation will have the necessary restrictions....

Screenshot 2022-01-18 at 09.09.25.png

Vishwas Rising Star Jan 18, 2022

Hey @Mikhail Ponomarev 

That's correct I have created using the "Create" button.

On the board while creating an issue restrictions are not applied, not sure why this behaviour(we may have to ask atlassian on this) but yes only summary can be given while creating issue on board and no other fields or restriction can be provided.

And in automation also you are right, restriction wont be applied.

Regards,

Vishwas

How can I raise it with Atlassian? I thought this post makes it... 

Hey @Mikhail Ponomarev 

Sure let me guide you, basically this is Community. Atlassian Team might respond here but they may take some time.

But to get faster response from support create a ticket here https://support.atlassian.com/contact/#/ 

Regards,

Vishwas

Like Mikhail Ponomarev likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events